Link:
Official OpenWRT Raspberry Pi Firmware Download
Expanding OpenWRT Squashfs Image (SD Card)
After a long awaited for internet fibre optic provided by ISP, finally the service available at my village. Since I’m in big family, the package chosen is 100 mbps package. Actually I’m looking to subscribe to other competitor ISP, but finally no choice since this one monopolized ISP has the control for initial registration system.
I’m provided with two devices, one is modem with optic connector and another is router with 2.4G and 5G WiFi, namely Tp-Link Archer C1200. I’ve noticed that the router seem to work very hard, until the processor usage reaching 100% at most of the time. As I read a lot many discussion and suggestion by user at online, as ISP will provide the cheapest device for user, therefore what your expectation with the performance?. That normal for business rite… lower the cost, increase in profit…
Finally why not take a try to change with other device for router, since I’ve got raspberry pi 3 and raspberry pi 4 in hand. The first project is done with Raspbery Pi 4 with 4 GB RAM. I’m following exactly the guide given by Yaroslav Koisa, both at Youtube and his website, and finally success. Yeahhh, but before that, I’m screwing my head with PPOE for TM Unifi, since its using virtual LAN 500 for internet and virtual LAN 600 for IPTV. Finally after hours searching, finally found this guide, in which need to edit manually file at /etc/config/network
Before that, since we have plenty of space by using sd card, the best option is to install all driver for USB Network, which the hardware available and supported by openwrt. Run the following command
opkg install kmod-usb-net && opkg install kmod-usb-net-aqc111 && opkg install kmod-usb-net-asix && opkg install kmod-usb-net-cdc-eem && opkg install kmod-usb-net-cdc-ether && opkg install kmod-usb-net-hso && opkg install kmod-usb-net-huawei-cdc-ncm && opkg install kmod-usb-net-ipheth && opkg install kmod-usb-net-kalmia && opkg install kmod-usb-net-kaweth && opkg install kmod-usb-net-mcs7830 && opkg install kmod-usb-net-pegasus && opkg install kmod-usb-net-pl && opkg install kmod-usb-net-qmi-wwan
opkg install kmod-usb-net-rndis && opkg install kmod-usb-net-rtl8150 && opkg install kmod-usb-net-rtl8152 && opkg install kmod-usb-net-sierrawireless && opkg install kmod-usb-net-smsc95xx && opkg install kmod-usb-net-sr9700 && opkg install kmod-usb-net2280 && opkg install kmod-usb-net-asix-ax88179
The sample as below, please suite with your LAN IP.
OpenWrt 23.05
/etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fda7:8199:6e65::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option type 'br-lan'
option proto 'static'
option ip6assign '60'
option device 'eth0'
list ipaddr '192.168.1.1/24'
list dns '1.1.1.1'
list dns '8.8.8.8'
config interface 'WAN'
option proto 'pppoe'
option device 'eth1.500'
option username 'yourusername@unifi'
option password 'yourpassword'
option ipv6 'auto'
option peerdns '0'
list dns '1.1.1.1'
list dns '8.8.8.8'
/etc/config/firewall
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option synflood_protect '1'
option drop_invalid '1'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
option input 'REJECT'
option forward 'REJECT'
list network 'WAN'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config forwarding
option src 'lan'
option dest 'wan'
Picture below is my Raspberry Pi 43 with OpenWRT 23.05 firmware.
For interface WAN, you need to rename it to eth1.500 instead of only eth1. Since I didn’t require for IPTV at eth1.600, I just ignore it.
Raspberry Pi 3 with OpenWRT, PPOE V500 finally work with TM Unifi fibre.. Luci with ClamAV, OpenVPN, Adblock, Squid and statistics graph. Memory usage about 16% so far. Average temperature 50 – 55. Stable connection detected, existing router now solely as Access Point for 2.4G and 5G WiFi. Yes, thumbs up to Single Board PC, good performance with low power consumption.
After done with Raspberry Pi 4, then I’m thinking to make the same thing with Raspberry Pi 3. Finally I’m decided to permanently with Raspberry Pi 3 since I’m not overkill this project with Raspi 4, further more the firmware still in shapshot stage. Thank you for those guys help me out with their article online.